posée par

Bonjour,
J'aimerai créer une formule sur Excel (sur une seule cellule) qui me permettra de déterminer le montant de la taxe à payer.
La taxe est variable en fonction du revenu comme expliqué ci-dessous:
De 0 à 800 000 c'est taxé à 0%
De 800 001 à 2 500 000 c'est taxé à 10%
De 2 500 001 à 7 500 000 c'est taxé à 20%
De 7 500 001 à plus c'est taxé à 30%.

Autre précision importante, les montants sont progressifs:
à supposer que le revenu est de 10 000 000, la formule va s'appliquer tel que suit:
800 000 à 0% pour la première tranche
(2 500 000 - 800 000) soit 1 700 000 taxés à10 % = 170 000 pour la deuxièmetranche
(7 500 000 - 2 500 000) soit 5 000 000 taxés à 20 % = 1 000 000 pour la troisième tranche
(10 000 000 - 7 500 000) soit 2 500 000 x 30% = 750 000 pour la quatrième tranche
Soit un impôt à payer = 170 000 + 1 000 000 + 750 000 = 1 920 000

Merci de me donner des orientations.

1 Réponse

1 j'aime 0 n'aiment pas
répondu par

Pour calculer une taxe progressive, avec Excel, vous pouvez utiliser les fonctions SOMMEPROD et RECHERCHEV.

Voici un bref descriptif de ces fonctions sur le site de Microsoft :

SOMMEPROD : https://support.office.com/fr-fr/article/fonction-sommeprod-16753e75-9f68-4874-94ac-4d2145a2fd2e
RECHERCHEV : https://support.office.com/fr-fr/article/fonction-recherchev-0bbc8083-26fe-4963-8ab8-93a18ad188a1

Voici un screenshot qui reprend vos données :

Les cellules E6, E7 et E8 affichent respectivement les formules des cellules C6, C7 et C8.

Formule C6

=SOMMEPROD(D14:D17-D13:D16;C5-B14:B17;--(C5>B14:B17))

Formule C7

=RECHERCHEV(C5;B14:D17;3;VRAI)

Formule C8

=C6/C5

commentée par

Bonjour,

Merci d'avoir pris votre temps pour me trouver une solution qui marche correctement malgré que je n'arrive pas à comprendre la formule, l'essentiel le résultat y est!

En outre, si j'ai plusieurs revenus dont j'aimerais rechercher le montant de la taxe à payer, comment procéder ou faut-il entrer les valeurs une à une ?

En résume, en colonne A1 à A300 le revenu et en colonne B1 à B300 j'aimerai avoir le montant de la taxe.

Merci encore

commentée par
edité

Pré-requis :

  • Conserver la première feuille tel que celle décrite ci-dessus.
  • Nommer cette première feuille Feuil0 (clic droit sur l'onglet de la feuille en bas d'Excel pour la renommer).
  • Créer une seconde feuille et la nommer par exemple Feuil1.

Sur Feuil1 :

  • Saisir tous vos revenus dans la colonne A.
  • Appliquer la formule suivante à la cellule B1.

Formule Cellule B1 :

=SOMMEPROD(Feuil0!$D$14:Feuil0!$D$17-Feuil0!$D$13:Feuil0!$D$16;A1-Feuil0!$B$14:Feuil0!$B$17;--(A1>Feuil0!$B$14:Feuil0!$B$17))

Appliquez ensuite la formule à toute la colonne B en sélectionnant la cellule B1 et en glissant vers la bas (de B1 à B300 par exemple)

Remarque : Feuil0! permet de sélectionner une cellule de la Feuille 0.

Remarque : Saisir $D$14 au lieu de D14 permet de ne pas incrémenter de 1 la cellule concerné lorsque vous étendez la formule aux autres cellules de la colonne B. Seul la valeur A1 sera incrémentée de 1 pour récupérer les valeurs de A2, A3 etc. C'est pour cette raison qu'on écrit A1 au lieu de $A$1 dans la formule.

Contenu pertinent

Questions liées

1 réponse
1 réponse
posée par anonyme 15-Janvier-2018
1 réponse
1 réponse

Merci pour votre visite sur 1FORMATIK.com

Un petit clic sur la pub est toujours apprécié, c'est elle qui finance le site

Bon surf

...